re = /^(?=.*\d)(?=.*[^a-zA-Z0-9\n])(?=.*[a-z])(?=.*[A-Z])(?!.*([a-zA-Z0-9])\1\1).{6,20}$/m
str = 'asA112!
asA111@'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end