package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d{5}(?:[-]\d{4})?|\d{9})$`)
var str = `12345
123456789
12345-6789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}