$re = '/^(?:\d{5}(?:[-]\d{4})?|\d{9})$/m';
$str = '12345
123456789
12345-6789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);