# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([0-9]+)(?:-([0-9]+)|\s*over)//gmix;t' <<< "'m trying to match speed descriptions of highway tickets, for example,text lines:
\"L A 16-25MPH\" should return 2 groups: 16, 25
\"LIMITED ACCESS SPEED I-75\" should return no matches.
\"LMT ACC 6-10\" should return 2 groups: 6, 10
\"6 OVER\" should return 1 group: 6
I'm OK with all of the above situations, but I run into issues for strings with numbers that aren't related to speed, for example:
"