package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mix)([0-9]+)(?:-([0-9]+)|\s*over)`)
var str = `'m trying to match speed descriptions of highway tickets, for example,text lines:
"L A 16-25MPH" should return 2 groups: 16, 25
"LIMITED ACCESS SPEED I-75" should return no matches.
"LMT ACC 6-10" should return 2 groups: 6, 10
"6 OVER" should return 1 group: 6
I'm OK with all of the above situations, but I run into issues for strings with numbers that aren't related to speed, for example:
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}