re = /mul\((\d{1,3}),(\d{1,3})\)/m
str = 'xmul(2,4)%&mul[3,7]!@^do_not_mul(5,5)+mul(32,64]then(mul(11,8)mul(8,5))
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end