package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[0-9,(,),+,_,#,~,-]{1,45}$`)
var str = `0397872743`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}