$re = '/^[0-9,(,),+,_,#,~,-]{1,45}$/';
$str = '0397872743';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);