using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:[0-9A-Fa-f]{2}(?=([-:\.]|))(?:\1[0-9A-Fa-f]{2}){5}))";
string input = @"13:14:5f:cD:42:5f
13-14-5f-cD-42-5f
13.14.5f.cD.42.5f
13145fcD425f
13-145f:cD425f";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}