import re
regex = re.compile(r"(?:(?:[0-9A-Fa-f]{2}(?=([-:\.]|))(?:\1[0-9A-Fa-f]{2}){5}))", flags=re.MULTILINE)
test_str = ("13:14:5f:cD:42:5f\n"
"13-14-5f-cD-42-5f\n"
"13.14.5f.cD.42.5f\n"
"13145fcD425f\n"
"13-145f:cD425f")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")