#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Building: )[A-Z]+(?: (?!UNIT\b)[A-Z]+\b)*"
Local $sString = "Building: BUILDING ONE 15 [building name followed by unit number]" & @CRLF & _
"Optional preceding text Building: BUILDING ONE 15 [preceding text, then building name followed unit number]" & @CRLF & _
"Building: BUILDING ONE UNIT 15 [building name followed by word UNIT and unit number]" & @CRLF & _
"Building: BUILDING ONE Floor 2 [building name followed by mixed case word]" & @CRLF & _
"Grounds: OPEN SPACE WEST Section 3 [not a building - return nothing]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")