#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\s*batman (\d+) batman\s*)"
Local $sString = "#capture" & @CRLF & _
"batman 12345 batman" & @CRLF & _
"batman 234 batman" & @CRLF & _
"batman 35655 batman" & @CRLF & _
"batman 1311 batman" & @CRLF & _
"#capture" & @CRLF & _
"" & @CRLF & _
"#others" & @CRLF & _
"batman 12345 batman" & @CRLF & _
"batman 234 batman" & @CRLF & _
"batman 35655 batman" & @CRLF & _
"batman 1311 batman" & @CRLF & _
"#others"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")