re = /(\s*batman (\d+) batman\s*)/
str = '#capture
batman 12345 batman
batman 234 batman
batman 35655 batman
batman 1311 batman
#capture
#others
batman 12345 batman
batman 234 batman
batman 35655 batman
batman 1311 batman
#others'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end