using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bdog\b(?!(?:[^""]*""[^""]*"")*[^""]*$)";
string input = @"Dog sighed. ""I'm no super dog, nor special dog,"" said Dog, ""I'm an ordinary dog, now leave me alone!"" Dog pushed him away and made his way to the other dog.";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}