re = /\bdog\b(?!(?:[^"]*"[^"]*")*[^"]*$)/i
str = 'Dog sighed. "I\'m no super dog, nor special dog," said Dog, "I\'m an ordinary dog, now leave me alone!" Dog pushed him away and made his way to the other dog.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end