#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\b(?:Lake|Tree)\b.*\bMan\b|\bMan\b.*\b(?:Tree|Lake)\b"
Local $sString = " [0] => sth!Man!Tree!null" & @CRLF & _
" [1] => sth!Maning!AppTree!null" & @CRLF & _
" [2] => sth!Man!Lake!null" & @CRLF & _
" [3] => sth!Man!Tree!null" & @CRLF & _
" [4] => sth!Man!AppTree!null" & @CRLF & _
" [5] => sth!Maning!AppTree!null" & @CRLF & _
" [6] => sth!Man!Tree!null" & @CRLF & _
" [7] => sth!Maning!AppTree!null" & @CRLF & _
" [8] => sth!Maning!AppTree!null" & @CRLF & _
" [9] => sth!Man!Tree!null" & @CRLF & _
" [10] => sth!Man!Tree!null" & @CRLF & _
" [11] => sth!Man!Tree!null" & @CRLF & _
" [12] => sth!Man!Tree!null" & @CRLF & _
" [12] => sth!Man!Lake!null" & @CRLF & _
" [13] => sth!Maning!Tree!null"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")