import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\\b(?:Lake|Tree)\\b.*\\bMan\\b|\\bMan\\b.*\\b(?:Tree|Lake)\\b";
final String string = " [0] => sth!Man!Tree!null\n"
+ " [1] => sth!Maning!AppTree!null\n"
+ " [2] => sth!Man!Lake!null\n"
+ " [3] => sth!Man!Tree!null\n"
+ " [4] => sth!Man!AppTree!null\n"
+ " [5] => sth!Maning!AppTree!null\n"
+ " [6] => sth!Man!Tree!null\n"
+ " [7] => sth!Maning!AppTree!null\n"
+ " [8] => sth!Maning!AppTree!null\n"
+ " [9] => sth!Man!Tree!null\n"
+ " [10] => sth!Man!Tree!null\n"
+ " [11] => sth!Man!Tree!null\n"
+ " [12] => sth!Man!Tree!null\n"
+ " [12] => sth!Man!Lake!null\n"
+ " [13] => sth!Maning!Tree!null";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}