package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"*([^"]*)"*,"*([^"]*)"*`)
var str = `rec3 col1,"rec3\ncol2"`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}