$re = '/"*([^"]*)"*,"*([^"]*)"*/';
$str = 'rec3 col1,"rec3\\ncol2"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);