re = /^(?(?!SS|WW)[A-HJ-NP-TV-Z]{2})[0-9]{3}(?(?!SS)[A-HJ-NP-TV-Z]{2})$/
str = 'AA000AA
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end