const regex = /\s(?=\S*:)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s(?=\\S*:)', 'gm')
const str = `A:Hey B:Are C:You there`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);