$re = '/\s(?=\S*:)/m';
$str = 'A:Hey B:Are C:You there';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;