#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:http:\/\/)(.*?)\/(.+?)(?:\/|\?|\#|$|\n)\w*.jpg"
Local $sString = "<div style="padding-right: 16px;"> <img class="img-thumbnail gamedetailthumb" src="http://images.cdn.spilcloud.com/thumbs-1-5/200X120_162615.jpg"> <img class="img-thumbnail gamedetailthumb" src="http://images.cdn.spilcloud.com/thumbs-1-5/120X90_162615.jpg"> <img class="img-thumbnail gamedetailthumb" src="http://images.cdn.spilcloud.com/thumbs-1-5/100X75_162615.jpg"> </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")