import Foundation
let pattern = ##"(?:http:\/\/)(.*?)\/(.+?)(?:\/|\?|\#|$|\n)\w*.jpg"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<div style="padding-right: 16px;"> <img class="img-thumbnail gamedetailthumb" src="http://images.cdn.spilcloud.com/thumbs-1-5/200X120_162615.jpg"> <img class="img-thumbnail gamedetailthumb" src="http://images.cdn.spilcloud.com/thumbs-1-5/120X90_162615.jpg"> <img class="img-thumbnail gamedetailthumb" src="http://images.cdn.spilcloud.com/thumbs-1-5/100X75_162615.jpg"> </div>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)