$re = '/^[1-9]\d{0,2}(?:,\d{1,3})?$/m';
$str = 'Allowed:
100
999,0
999,999
999,99
Disallowed:
-1
0
999,
999,9999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);