// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[1-9]\d{0,2}(?:,\d{1,3})?$").unwrap();
let string = "Allowed:
100
999,0
999,999
999,99
Disallowed:
-1
0
999,
999,9999";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}