using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)(-.*)";
string substitution = @"\U$1\E$2";
string input = @"Apple - Orange - Banana - Filename.txt
Grape - Orange - Banana - Filename.txt
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}