// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*?)(-.*)").unwrap();
let string = "Apple - Orange - Banana - Filename.txt
Grape - Orange - Banana - Filename.txt
";
let substitution = "\\U$1\\E$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}