using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"function\s*\w+\s*\(\s*(\w+,?){3,10}";
string input = @"function foobar (absad";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}