$re = '/function\s*\w+\s*\(\s*(\w+,?){3,10}/';
$str = 'function foobar (absad';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);