$re = '/(?<!\.)(?:[1-9]\d{3,}|9(?:[6-9]\d|5[5-9]))(?:\.\d+)?/';
$str = '0004
27.955
55
111
954
I must have eaten 955 eggs
962
975.25
1000
01025
0007926.999
999999
9999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);