# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\.)(?:[1-9]\d{3,}|9(?:[6-9]\d|5[5-9]))(?:\.\d+)?"
test_str = ("0004\n"
"27.955\n"
"55\n"
"111\n"
"954\n"
"I must have eaten 955 eggs\n"
"962\n"
"975.25\n"
"1000\n"
"01025\n"
"0007926.999\n"
"999999\n"
" 9999")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.