$re = '/(?!^)(\d{2})(?=(?:\d{2})*$)/m';
$str = '1215464565';
$subst = "-$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;