$re = '/(?=<!--)([\s\S]*?)-->/';
$str = '<!---- Something here < ssww ==- >- -> --->';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);