re = /(?=<!--)([\s\S]*?)-->/
str = '<!---- Something here < ssww ==- >- -> --->'
# Print the match result
str.match(re) do |match|
puts match.to_s
end