package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w-\w`)
var str = `First-file-111-222.txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}