$re = '/\w-\w/';
$str = 'First-file-111-222.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);