const regex = /img[\s]*src.*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('img[\\s]*src.*', '')
const str = `.test(“24db6"#@!/><img src”)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}