package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([1-9][0-9]|[0-9][1-9])[0-9]{4,}$`)
var str = `00123456
12345
01123456
12123456
80123456
11123456
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}