use strict;
my $str = 'hello world
str
string
String
CString
bool
boolean
Boolean
isize
usize
u128
I64
u_32
0i16
uu8
i4
char
Char
_char
_Char
character
_character
T
N
Type
NUM
snake_case
camelCase
PascalCase
SCREAMING_SNAKE_CASE
_snake_case1
_camelCase2
_PascalCase3
_SCREAMING_SNAKE_CASE4
1snake_case
2camelCase
3PascalCase
4SCREAMING_SNAKE_CASE';
my $regex = qr/^(?:
(
(?:bool|char|str)
|(?:[fiu](?:32|64))
|(?:[iu](?:8|16|128|size))
)|(
_*[A-Z][a-zA-Z0-9_]*
)
)$/xmp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}