import re
regex = re.compile(r"""
^(?:
(
(?:bool|char|str)
|(?:[fiu](?:32|64))
|(?:[iu](?:8|16|128|size))
)|(
_*[A-Z][a-zA-Z0-9_]*
)
)$
""", flags=re.VERBOSE | re.MULTILINE)
test_str = ("hello world\n\n"
"str\n"
"string\n"
"String\n"
"CString\n\n"
"bool\n"
"boolean\n"
"Boolean\n\n"
"isize\n"
"usize\n"
"u128\n"
"I64\n"
"u_32\n"
"0i16\n"
"uu8\n"
"i4\n\n"
"char\n"
"Char\n"
"_char\n"
"_Char\n"
"character\n"
"_character\n\n"
"T\n"
"N\n"
"Type\n"
"NUM\n\n"
"snake_case\n"
"camelCase\n"
"PascalCase\n"
"SCREAMING_SNAKE_CASE\n\n"
"_snake_case1\n"
"_camelCase2\n"
"_PascalCase3\n"
"_SCREAMING_SNAKE_CASE4\n\n"
"1snake_case\n"
"2camelCase\n"
"3PascalCase\n"
"4SCREAMING_SNAKE_CASE")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")