#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ix)#opening tag" & @CRLF & _
"\{(RAW|ACCESS|DWNLINK|MODL|\w+)" & @CRLF & _
" #optional attributes" & @CRLF & _
" (?>" & @CRLF & _
" \{ ([^}]*) }" & @CRLF & _
" )?" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"#optional text and closing tag" & @CRLF & _
"(?:" & @CRLF & _
" ( #text:= any char except "{", or a "{" not followed by /commandname" & @CRLF & _
" [^{]*+" & @CRLF & _
" (?>\{(?!/?\1[{}])[^{]*)*?" & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
" #closing tag" & @CRLF & _
" \{/\1}" & @CRLF & _
")?"
Local $sString = "<div class="blog-list-item blog"><header class="entry-title">" & @CRLF & _
" <h1>Welcome to our website</h1>" & @CRLF & _
" </header><article id="entry-72" class="entry post-72 page et-bg-layout-dark et-white-bg"><div class="jumbotron row">" & @CRLF & _
"<div class="col-md-8">" & @CRLF & _
"<ul>" & @CRLF & _
"<li>You have a pending job on your neck?…</li>" & @CRLF & _
"<li>Do your company need a website makeover ?…</li>" & @CRLF & _
"<li>Or a competitive web application ? ?…</li>" & @CRLF & _
"<li>Do you need a customized plugin, or a tweak ?…</li>" & @CRLF & _
"<li>Maybe you want a personal website ?…</li>" & @CRLF & _
"<li>Or a graphic for your new project ?…</li>" & @CRLF & _
"</ul>" & @CRLF & _
"<div class="bg-primary well">" & @CRLF & _
"<h4 class="text-center text-white shadow">Track your project as we work it to perfection...</h4>" & @CRLF & _
"</div>" & @CRLF & _
"</div>" & @CRLF & _
"<div class="pull-right col-md-4">" & @CRLF & _
"<h4 class="bg-primary text-white well">Other services we offer</h4>" & @CRLF & _
"{ACCESS{type=500}}" & @CRLF & _
"<ul>" & @CRLF & _
"<li>SEO work for an existing website or new</li>" & @CRLF & _
"<li>Bulk SMS</li>" & @CRLF & _
"<li>E-currency exchange</li>" & @CRLF & _
"<li>Facebook AD</li>" & @CRLF & _
"<li>Google AD</li>" & @CRLF & _
"</ul>" & @CRLF & _
"{/ACCESS}</div>" & @CRLF & _
"{RAW{say=email,access=500}} {RAW} <a class="btn button large tall green" href="client-area">Place new Job now as we deliver at the quickest <em>reasonable time</em></a>{/RAW}</div></article></div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")