# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
#opening tag
\{(RAW|ACCESS|DWNLINK|MODL|\w+)
#optional attributes
(?>
\{ ([^}]*) }
)?
}
#optional text and closing tag
(?:
( #text:= any char except "{", or a "{" not followed by /commandname
[^{]*+
(?>\{(?!/?\1[{}])[^{]*)*?
)
#closing tag
\{/\1}
)?
"""
test_str = ("<div class=\"blog-list-item blog\"><header class=\"entry-title\">\n"
" <h1>Welcome to our website</h1>\n"
" </header><article id=\"entry-72\" class=\"entry post-72 page et-bg-layout-dark et-white-bg\"><div class=\"jumbotron row\">\n"
"<div class=\"col-md-8\">\n"
"<ul>\n"
"<li>You have a pending job on your neck?…</li>\n"
"<li>Do your company need a website makeover ?…</li>\n"
"<li>Or a competitive web application ? ?…</li>\n"
"<li>Do you need a customized plugin, or a tweak ?…</li>\n"
"<li>Maybe you want a personal website ?…</li>\n"
"<li>Or a graphic for your new project ?…</li>\n"
"</ul>\n"
"<div class=\"bg-primary well\">\n"
"<h4 class=\"text-center text-white shadow\">Track your project as we work it to perfection...</h4>\n"
"</div>\n"
"</div>\n"
"<div class=\"pull-right col-md-4\">\n"
"<h4 class=\"bg-primary text-white well\">Other services we offer</h4>\n"
"{ACCESS{type=500}}\n"
"<ul>\n"
"<li>SEO work for an existing website or new</li>\n"
"<li>Bulk SMS</li>\n"
"<li>E-currency exchange</li>\n"
"<li>Facebook AD</li>\n"
"<li>Google AD</li>\n"
"</ul>\n"
"{/ACCESS}</div>\n"
"{RAW{say=email,access=500}} {RAW} <a class=\"btn button large tall green\" href=\"client-area\">Place new Job now as we deliver at the quickest <em>reasonable time</em></a>{/RAW}</div></article></div>")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.