package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`XYBC\d+`)
var str = `Viuhaskfdksjfkds XYBC4975723434 fkdsjkfjaksjfklsdakldjsen`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}