re = /XYBC\d+/
str = 'Viuhaskfdksjfkds XYBC4975723434 fkdsjkfjaksjfklsdakldjsen'
# Print the match result
str.match(re) do |match|
puts match.to_s
end