import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\*[\\s\\S]*?\\*\\/";
final String string = "/*@comment\n\n"
+ " @title: Buttons\n"
+ " @name: block-name\n"
+ " @category: Category name > Sub category\n"
+ " @description: This is the description of the element\n"
+ " @html:\n"
+ " <div class=\"block-name\"></div>\n\n"
+ "*/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}