const regex = /(.+?)(?:\s\((\d+)\))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+?)(?:\\s\\((\\d+)\\))?$', 'gm')
const str = `John Smith
John Smith (123)
John Smith (123) (456)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}