re = /(.+?)(?:\s\((\d+)\))?$/m
str = 'John Smith
John Smith (123)
John Smith (123) (456)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end