package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^(\r\n]+$|.*(?:\((.*)\)))`)
var str = `John Smith
John Smith (123)
John Smith (123) (456)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}