$re = '/^([^(\r\n]+$|.*(?:\((.*)\)))/m';
$str = 'John Smith
John Smith (123)
John Smith (123) (456)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);